1
0
Fork 0
wasp-os/tools/nix/shell.nix
Francesco Gazzetta bf07f0cf55 tools/nix: fix wasptool
Fixes "ImportError: cannot import name GLib, introspection typelib not found"

Signed-off-by: Francesco Gazzetta <fgaz@fgaz.me>
2024-09-30 09:26:53 +01:00

39 lines
695 B
Nix

{ pkgs ? import <nixpkgs> {} }:
let
# wasptool and ota-dfu only work on linux, and their dependencies prevent the
# shell to evaluate on darwin
ifLinux = pkgs.lib.optionals pkgs.stdenv.isLinux;
in pkgs.mkShell {
buildInputs = ifLinux [
pkgs.gobject-introspection
];
nativeBuildInputs = [
(pkgs.python3.withPackages (pp: with pp; [
cbor
click
cryptography
dbus-python
numpy
pexpect
pillow
pygobject3
pysdl2
pyserial
tomli
pytest
# Docs
recommonmark
sphinx
] ++ ifLinux [
bluepy
]))
pkgs.gcc-arm-embedded-11
pkgs.graphviz
] ++ ifLinux [
pkgs.bluez
];
}