047b320b63
Usually it's a bad idea, but here the disk uuids are actually changing more often as we rebuild the VM.
64 lines
1.8 KiB
Nix
64 lines
1.8 KiB
Nix
# This file was generated by running nixos-generate-config on the VM.
|
||
#
|
||
# Do not modify this file! It was generated by ‘nixos-generate-config’
|
||
# and may be overwritten by future invocations. Please make changes
|
||
# to /etc/nixos/configuration.nix instead.
|
||
{ config, lib, pkgs, modulesPath, ... }:
|
||
|
||
{
|
||
imports =
|
||
[ (modulesPath + "/profiles/qemu-guest.nix")
|
||
];
|
||
|
||
boot.initrd.availableKernelModules = [ "ata_piix" "uhci_hcd" "virtio_pci" "floppy" "sr_mod" "virtio_blk" ];
|
||
boot.initrd.kernelModules = [ ];
|
||
boot.kernelModules = [ "kvm-intel" ];
|
||
boot.extraModulePackages = [ ];
|
||
|
||
fileSystems."/" =
|
||
{ device = "/dev/vda";
|
||
fsType = "ext4";
|
||
};
|
||
|
||
fileSystems."/nix/.ro-store" =
|
||
{ device = "nix-store";
|
||
fsType = "9p";
|
||
};
|
||
|
||
fileSystems."/nix/.rw-store" =
|
||
{ device = "tmpfs";
|
||
fsType = "tmpfs";
|
||
};
|
||
|
||
fileSystems."/tmp/shared" =
|
||
{ device = "shared";
|
||
fsType = "9p";
|
||
};
|
||
|
||
fileSystems."/tmp/xchg" =
|
||
{ device = "xchg";
|
||
fsType = "9p";
|
||
};
|
||
|
||
fileSystems."/nix/store" =
|
||
{ device = "overlay";
|
||
fsType = "overlay";
|
||
};
|
||
|
||
fileSystems."/boot" =
|
||
{ device = "/dev/vdb2";
|
||
fsType = "vfat";
|
||
};
|
||
|
||
swapDevices = [ ];
|
||
|
||
# Enables DHCP on each ethernet and wireless interface. In case of scripted networking
|
||
# (the default) this is the recommended approach. When using systemd-networkd it's
|
||
# still possible to use this option, but it's recommended to use it in conjunction
|
||
# with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
|
||
networking.useDHCP = lib.mkDefault true;
|
||
# networking.interfaces.eth0.useDHCP = lib.mkDefault true;
|
||
|
||
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
|
||
hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
|
||
}
|